‎Outdoor Camera won’t reset or re-connect | SimpliSafe Support Home
 
rlarue's profile

Sunday, October 9th, 2022 4:11 AM

Outdoor Camera won’t reset or re-connect

My outdoor camera battery drained, even though it was hooked up to solar. After fully recharging the battery, it would not reconnect. I removed the camera and tried to add it back, but instead of chiming and blinking white it goes right to flashing a blue light and would not connect with the base station. Holding the back button does not result in a reset. The light simply stays flashing blue. How else can I reset this thing? 

1 Message

2 years ago

mine is doing the same have you received a answer on this yet 

2 Messages

@mcgeebartjr​ After talking with customer service they have decided to send a replacement camera.

1 Message

This has happened to me three times over the course of a year. Now my device is out of warranty and I'm stuck with another bricked camera.

Community Admin

 • 

5.3K Messages

@chad_j​ that shouldn't mean you're out of options. Have you already been working with our Support team? We can put you in touch with a specialist who can help.

Advocate

 • 

929 Messages

@chad_j​ if you have the interactive plan you have a lifetime warranty on all devices including cameras 

Community Admin

 • 

5.3K Messages

2 years ago

Hi @rlarue ,

Sounds like a firmware or programming issue that froze the camera and prevents it from rebooting. I agree with the solution of replacing the camera. @mcgeebartjr , our Support team can help with that.

3 Messages

I have the same problem.  Tried everything with support and the camera will not reset... just flashes blue forever.  I need a new outdoor camera, also.  Who can help me with this??

Community Admin

 • 

5.3K Messages

@aaronz​ sounds like you're experiencing this known issue. Please follow the link for troubleshooting and further steps.

1 year ago

I have the same problem of camera blinking blue and will not reset or communicate.  Would be nice to have a posted response or a video about what to do.

Community Admin

 • 

240 Messages

Hello @drkkirkpatrick​,

Based on those symptoms it would be best for you to reach out to our support team. You can connect with them via chat (bottom right corner of this page) or by phone with the contact details here

1 Message

9 months ago

I had the same issue with both my outdoor cameras i.e. flashing blue upon insertion of the batteries after removing both from the system. I removed both because I could no longer acquire a live view.  I stumbled upon resolving the problem by inserting the batteries and immediately pressing and holding the setup button until the camera starting flashing white. I was then able to follow the instructions and add the camera back online. 

1 Message

whitefrank's procedure actually worked.  It took about 4 or 5 tries and holding down the reset button about 2 minutes and then repressing it again for a second or so when the system requested, but it finally worked.  I was on the edge of giving up, but patience is definitely a virtue when dealing with the outdoor camera and the system in general.

New to the Community? Get started by reading our Welcome Post.