‎Simplisafe app not working after latest iOS update, 15.6 | SimpliSafe Support Home
 
benjaminkurata's profile

Saturday, July 23rd, 2022 9:07 PM

Simplisafe app not working after latest iOS update, 15.6

Can't log in on my iPhone - if there's a captcha on the phone app, can't see it.

Current login and password work just fine from my two laptops.

Accepted Solution

10 Messages

2 years ago

NEVER MIND, I FIXED IT MYSELF!

So SimpliSafe added a reCaptcha to their smartphone app.  Only it doesn't show up in Apple iOS unless you:

Settings > Safari > Scroll forever to the last item, "Advanced" > Javascript > On

App works fine now.

Accepted Solution

2 years ago

I've had the same problem! My JavaScript was already toggled on, but that sent me down the right path.

What fixed it for me was: Settings > Safari > scroll to the bottom for "Settings For Websites" section > Content Blockers > toggle off "All Websites". That made the reCaptcha appear after I force quit/reloaded SimpliSafe app.

Once I'm logged in, looks like I can turn Content Blockers back on... Just gotta remember for the next time.

5 Messages

@GermanShepherd​ 

Hi! I am at a complete loss ... where is this setting? I have a "Settings for Websites" section, but only a "Share Across Devices" option is available. 

10 Messages

2 years ago

Yes, I power cycled my phone after the iOS update.

Yes, I deleted the app and downloaded it again.

The app doesn't appear on the Settings > Notifications, so I'm not getting ANY system notifications.

5 Messages

@benjaminkurata​ Same here - the app installs, but never shows up with the other apps in the "Notifications" section. 

Community Admin

 • 

242 Messages

2 years ago

ReCaptcha was recently, and temporarily, added to authenticate logins to SimpliSafe accounts. Thank you @benjaminkurata and @GermanShepherd for taking those steps and verifying that they worked to resolve the issue. I have gone ahead and marked these as an 'Accepted Solution' as this should help to resolve the issue for anyone else currently having trouble logging in to their account. 

If you run into any issues logging in to your account in the future, or have any other questions, don't hesitate to reach back out.

1 Message

2 years ago

All of the sudden, the app is not working on my iphone.  I did rebooted, deleted the app and the Safari/Java recommendation.  However, app is still not working.

Community Admin

 • 

5.5K Messages

Sorry to hear that. What version of the SimpliSafe app are you on now? You can check through the SimpliSafe page in your phone's App Store. If there's a new update available, you should install it ASAP.

5 Messages

2 years ago

I've tried to try the above methods, I have had several chats with SS via phone and online chat ... without the app, my use of the cameras is definitely diminished!

This comment has been converted into a post

Community Admin

 • 

5.5K Messages

Hi @paulgeary,

 

I split off your question to a new thread so we can go more in-depth with your issue. Based on your other posts, I'm not sure what you're having trouble with. Is it that you're not able to log into the SimpliSafe app? Or that you have been able to log in, but you're not able to enable Push Notifications?

 

To help with troubleshooting, it would also be useful to know what device you are using (your phone model), as well as what version of the SimpliSafe app you are currently on. On iOS, you can find that out by navigating to the SimpliSafe page in the App Store.

11 Messages

I like many others above have had issues with the app.


I have uninstalled, and reinstalled it. So it’s the latest. My phone is fully up to date with with latest iOS. 

The app shows the set up screen as if I haven’t set  up my system yet. This means I cannot arm or disarm it and I do not get notifications. 

However the website version of it works on safari to arm and disarm it.

This issue has been throughly disappointing and frustrating!!

1 Message

@davey_d​ i am struggling with this as well

5 Messages

@davey_d​ 

The app, Simpli, does not work.

I have tried all of the "solutions" I have found here, on Reddit, etc. I have spoken to customer service via phone and chat numerous times. And still I cannot get the app to recognize my system.

All of this running around has not exceeded the 60 day return window, but without the app, much of the reasons why I bought this system in the first place are rendered moot.

If this can't be resolved, I will need to return our equipment and ask for a refund.

I am having the exact issues, just about ready to send thier stuff back… Getting now where for the last 3 weeks. SIMPLYSAFE, fix this or loose lots of new customers.  It’s your Mob App server, get some experts on it. 

1 Message

2 years ago

I’ve deleted and reinstalled the app and still cannot receive “push notifications “. It tells me that the app in stopping the ability to have the “push notifications “. 
I have IOS 11. I have downloaded all updates! 
I have spoken with SS twice and my phone carrier twice.      PLEASE HELP!!!!! 

1 Message

2 years ago

Tried all of these suggestions, app was working now it is not. Just get "oops something went wrong", iPhone 8 plus iOS 16.2.  Logging in through various web browsers works just fine.  Just cannot get into it from the phone app.

5 Messages

2 years ago

So, finally, the app works. I'm not sure when, but an update must have been pushed out. 

8 Messages

2 years ago

For several weeks Ive been unable to get the app to work. It's been updated regularly, etc.. I decided to log out, and when I logged back in the app worked properly.

New to the Community? Get started by reading our Welcome Article and please be sure to review our Community Guidelines before posting.