‎Check Internet Connection | SimpliSafe Support Home
 
W

Friday, November 6th, 2020 6:58 PM

Check Internet Connection

Hi,

I've just setup my new Simplisafe system but when trying to subscribe I always get a 'Check Internet Connection' error at payment, I've tried via the app and from my desktop PC, same error.

Can someone help?

To confirm the hub is connected to WiFi, keypad confirms this, and I can view the cam through the app so isn't an Internet issue?

Thanks in advance

Advocate

 • 

2.8K Messages

3 years ago

Not sure what you mean by, when trying to subscribe I always get a 'Check Internet Connection' error at payment?  If you're still in set-up steps and activation, you should give SS a call for assistance.

1 Message

3 years ago

I receive the same "Check internet connection" popup when I try to download the Monitoring Certificate.

1 Message

3 years ago

Getting the same thing. I just submitted a note to Support.

Community Admin

 • 

521 Messages

3 years ago

Hi all,

Thanks for letting us know about this issue. This has been fixed as of a little after 11 AM ET this morning. If anyone else continues to have an issue similar to this, please contact our Support Team to see what we can do.

SimpliSafe Social Team
SimpliSafe Home Security

Advocate

 • 

2.8K Messages

3 years ago

SS, you seem to be having a few too many server issues lately, what's the deal?

1 Message

3 years ago

I'm in the UK here, and getting the same "Check Internet connection" when getting to the payment page.  Any ideas what I'm doing wrong?

3 Messages

3 years ago

I have got the same problem today in the UK.  I have sent an email to support!

2 Messages

3 years ago

Has anybody had a this issue fixed - having the same problem and no response from SS as of yet.

3 Messages

They responded to my email last night saying that they are working to fix the problem.  They also said that I would need to speak to them to get connected and that they would phone me today to walk me through the process.

3 Messages

3 years ago

Ok, I ended up calling them and they were very efficient sorting it out.  They basically activated the service from their side.

2 Messages

Thank you, I will give them a call after work.

3 Messages

3 years ago

I'm thinking they may need to do the same with mine

1 Message

2 years ago

A year later and this is still an issue? Does not bode well for my hopes that this will be a decent security system if they can’t even take my money!

Community Admin

 • 

5.3K Messages

@sharonb78​ sorry about the trouble. Of course, if you haven't already, you can call our Support team at 800-548-9508 and we can make sure that your system is activated!

1 Message

2 years ago

I just spent a lot of time on the phone with the support. We replaced batteries, installed an update, reinstalled the app multiple times and tried a lot of other things with no success. They will send me a new base station now but I have a strong suspicion that won’t help either. Pretty frustrating.

7 Messages

2 years ago

Still an issue, not looking good for my new purchase, first i cant auto arm, and now cant even subscribe to new service, kinda seems like that would be a top priority for a company.... you know, making money with new customers...

1 Message

7 months ago

Looks like same issue for over 3 years... Logged into control panel, but getting "Check Internet Connection" when trying to download Monitoring Certificate

Same here too. Wth cant keep the servers up?

Community Admin

 • 

2.7K Messages

@danjmoore and @fandhsolutions Thank you for reporting this! Our devs are currently working on getting this fixed soon. In the meantime, if you contact our Support team, they will be able to send you your Monitoring Certificate. 

New to the Community? Get started by reading our Welcome Post.