‎Outdoor camera died. | SimpliSafe Support Home
 
eamail2001's profile

98 Messages

 • 

10 Points

Sunday, October 16th, 2022 4:54 PM

Outdoor camera died.

Hi, So Friday I noticed my outdoor camera looked VERY foggy. It had been raining for 2+ days so thought maybe it just was. That night when it looked even worse, like something smeared on the lens. I took it down, pulled the battery out (90% full) and cleaned it off. When I put it back together it came on a looked the same.

The next day it was not working at all, dead. I reset the battery a few times but always dead. no light, sound, etc. I charged the battery just to make sure and still dead.  I called CS, and he walked me through a few things. most I already tried. He had me press the reset button by holding the button on the back for 10+ sec, but nothing.

On Monday he said someone from the camera tech department will call me to see if they can help.

This camera has been fine for 11 months. 

I wanted to post here to see if anyone had the same issue?

98 Messages

 • 

10 Points

1 year ago

Update: New camera being sent out.

Community Admin

 • 

5.2K Messages

 • 

70 Points

1 year ago

Hi @eamail2001 ,

Sounds like severe water damage - perhaps the seal wasn't as tight as it should have been. Definitely was a great idea to send a replacement.

1 Message

1 year ago

I have just had the same issue.  We have had sustained rain over a few days where I live. 

My camera appeared fogged up and was no longer detecting movement.  I brought the camera down as I thought the lens was dirty, and charged and replaced the battery.  I put the camera back up and noticed that it would no longer connect to the system.

I again got the camera down which is when I noticed that it had a constant red light, on opening up the camera I then noticed moisture around and coming out of the squarish contact point block in the back of the front camera housing.

I am currently in contact with simplisafe support over the issue.

Advocate

 • 

927 Messages

1 year ago

If it is just water on the lens I have put rain x on it and that solved my problem, I also had a problem where water got into the plug in back where I have the power cord in and water had damaged the plug part in camera so they sent another one so now I have a piece of flex tape on top of cameras and have it come down over the outlet part and so far so good, just trying to keep water out of them

2 Messages

4 months ago

Just had the same exact issue.  SS is sending me a replacement camera. Ive had a nest camera in the same location for five + years and NEVER EVER had an issue .  I think these outdoor cameras need a rework to make them at least equal to what NEST is using.  Why is it called an “outdoor” camera if it can’t withstand the outdoor weather conditions? If this replacement camera has the same issue, bye bye simplisafe !!! Not worth the aggravation.  

New to the Community? Get started by reading our Welcome Post.