‎installed new batteries in simplisafe base station but battery backup not working. | SimpliSafe Support Home
 
H

Thursday, December 3rd, 2020 4:48 PM

installed new batteries in simplisafe base station but battery backup not working.

installed new batteries in simplisafe base station (not the new version) but the battery backup still not working when disconnected from the outlet.  only works while connected to the wall outlet.

Community Admin

 • 

521 Messages

3 years ago

Hi @hanahou07,

When changing the backup batteries in your SimpliSafe system it's important to make sure that you are using four rechargeable NiMH batteries. If other types of batteries are used, it could cause harm to your system. If you are using the correct type of batteries and have given them plenty of time to charge up with the base station plugged in, then you may have to contact our Support Team for further troubleshooting. They can be reached by email at Customer-Support@SimpliSafe.com or by phone at 1-800-297-1605 from 8 AM to Midnight ET, 7 days a week.

SimpliSafe Social Team
SimpliSafe Home Security

2 Messages

1 year ago

I have been with SimpliSafe for years now since (Aug 2011). My older equipment worked fine. I just bought a new system to include new devices. On the first day an Entry Sensor did not work, you are sending a replacement, thank you. Now on the third day the Base Station does not have the ability to Refresh (can not communicate with SimpliSafe) using my computer or the Android phone app. This happens only on Battery, works when plugged into AC power; so now you are sending a replacement Base Station.  I am a bit concerned about the reliability of this "New Equipment". 

This comment has been converted into a post
New to the Community? Get started by reading our Welcome Post.