‎Door bell camera stopped working | SimpliSafe Support Home
 
rickc's profile

Tuesday, August 23rd, 2022 2:14 AM

Door bell camera stopped working

 after 2 years, now seems stuck in reboot mode yellow on for a few seconds then of for 30, repeat.  Took off wall,  reinstalled, removed from system. No success

Captain

 • 

5.7K Messages

 • 

130 Points

2 years ago

@rickc After 2 years and nothing has  changed, the unit may be fried. I would call SS support, troubleshoot and then, if necessary, have it replaced.

Question for SS: I know if you are on the top interactive 27 dollar monitoring plan, most hardware is covered as long as you continue your plan, but is all hardware covered under the 36 mo warranty? Is that still around? Thanks!

(edited)

Community Admin

 • 

240 Messages

2 years ago

@rickc When reinstalling the Video Doorbell Pro, did you perform a hard reset on the unit? If not, it's worth trying that to see if we can get the unit functioning again.

  • Remove the doorbell from its charging plate
  • Press the small button on the back of the doorbell for 10 seconds and then release
  • Place the doorbell back on its charging plate. There will then be a yellow light as it boots back up

If that doesn't do the trick, please reach out to our support team directly. They'll be able to go over your replacement options with you over the phone. Their contact details can be found here.

@captain11 For Interactive Monitoring Subscribers, there is a limited lifetime warranty on hardware. Other tiered subscriptions do have extended warranty options as well. Our warranty information can be found here.

Captain

 • 

5.7K Messages

 • 

130 Points

@alexandria_c​ Thank you for the link and post.  Article in the help center was perfect.

New to the Community? Get started by reading our Welcome Post.