‎Side Panel Links in Dashboard don't work in Firefox | SimpliSafe Support Home
 
simrick405's profile

Saturday, January 27th, 2024 7:55 PM

Side Panel Links in Dashboard don't work in Firefox

I have to manually type in the links I need, for example:

https://webapp.simplisafe.com/#/monitoring

I have to type in the word "monitoring" to get to that page.  Same with "cameras" and PINs and System - none of them work. It's been like this for quite a while. Can someone fix this please, or tell me what I'm doing wrong? Thanks.

Captain

 • 

5.8K Messages

3 months ago

@simrick405 I may be wrong but it sounds like a browser setting or incompatability. Try allowing 3rd party cookies or, better yet, call support for troubleshooting. After a browser update, my browser (Chrome) was not be compatible with some sites and I switched to Edge or Firefox until I figured it out.  BTW, does your app work okay? Again, suggest calling support.

(edited)

Community Admin

 • 

5.3K Messages

3 months ago

Hi @simrick405 ,

Thanks for reporting. I did test on firefox myself, and had no trouble. So there might be something you have different with your particular setup. I have some questions that might help get to the bottom of this:

  • What operating system are you using? Is this on a desktop, tablet, or phone?
  • Do you have javascript and cookies enabled?
  • Do you have any popup or adblockers installed?
  • Is Firefox up to date with the latest version? (I believe the latest version, released on 1/23/24, was v122.0)

3 Messages

3 months ago

Hi and thanks for your reply.

To answer your questions:

I'm using a desktop computer

Windows 10 65 bit 22H2 19045.3803

Yes, javascript & cookies are enabled

I did have uBlock Origin on, but have turned it off for Simplisafe websites (I made an exception in the blocker itself.)

FF v122.0

I've tried doing a clean refresh of the page (CTRL+F5) and that doesn't help.

It worked once, then stopped.

I was going to clear cookies & cache, but decided to log in first & test it, after having turned off the computer yesterday and back on today, and of course, it's working now. lol

I don't know what to say....but, thanks for your help!

3 Messages

3 months ago

And....I just went back to the page, and it has stopped working....lol I can't win!

Community Admin

 • 

2.6K Messages

@simrick405​ From time to time I have seen some issues using the web app when popup or ad blockers are installed; but since you turned yours off for SimpliSafe websites and there's still a problem loading the web app, I would recommend clearing cache and cookies next.

New to the Community? Get started by reading our Welcome Post.