‎Latest iOS Simplisafe app update has broken the iPhone app. | SimpliSafe Support Home
 
T

Sunday, January 12th, 2020 2:40 AM

Latest iOS Simplisafe app update has broken the iPhone app.

This is what the screen looks like on my iPhone.

I can access everything except arm/disarm.

My iPad has the older app and still works but I don't always bring an 11 iPad with me.

http://terrizamore.com/b/ss.png

1 Message

4 years ago

I've alerted them as well. I would expect an update coming fairly quickly to fix the new bug.

14 Messages

4 years ago

It's not the iOS update, it is the latest update of their iOS app that broke everything for us. I have have iOS 13.3 on all devices for weeks now and it worked. The the app update from yesterday broke it. I can only use my keypad now for arm or disarm.

Advocate

 • 

929 Messages

4 years ago

Another reason why I wait to do an update because they are knkw for having issues with updates so mine still works but i never updated and wifes doesn't work because she has hers to automatically update. So I'll wait until they fix it.

1 Message

4 years ago

Theres an update available now that fixes the IOS bug

9 Messages

4 years ago

iOS 13.3 is now available for the iPhone. I'm using an iPhone XR and it works perfectly. Make sure you have updated the app as well. There was an update pushed out today that, "Fixed system state controls." App version is now 2074.8.9.

Hope that helps.

12 Messages

4 years ago

Last night my iPad did its automatic updates so now SimpliSafe is broken on it too,

At least my Apple Watch's SimpiSafe app still works... most of the time.

12 Messages

4 years ago

Yea
I just found the update that came out today and fixes the issue.

4 Messages

4 years ago

I think some are talking about two different things.  The OP is talking about the latest update of the simplisafe app not ab ios update.  My phone has the current ios update and last night I got a notice that there was an updated version of the SS app available so I updated the app.  My screen is the same as the picture above that the OP posted.  The circles where you select "off" "home" or "away" are all white and you cannot select any of them.  Hopefully they get a fix soon.  

In the mean time does anyone know if there is a way to go back and download a previous version of the app?  Don't like not being able to use the app to run my system.

4 Messages

4 years ago

I just deleted and re installed the SS app and it seems to be working now.  So if you are having problems and have not tried that it is worth a shot.
New to the Community? Get started by reading our Welcome Post.