‎Persistent Connectivity Issues with SimpliSafe Outdoor Camera After Wi-Fi Router Upgrade | SimpliSafe Support Home
 
therikkening's profile

Wednesday, April 19th, 2023 10:58 PM

Persistent Connectivity Issues with SimpliSafe Outdoor Camera After Wi-Fi Router Upgrade

I'm reaching out for assistance with an ongoing issue involving my SimpliSafe outdoor camera that remains unresolved despite multiple troubleshooting attempts and receiving a replacement camera.

Since upgrading my Wi-Fi router to a newer model, my outdoor camera has stopped reliably recording videos during detection windows and consistently launching the live view feature. While I've occasionally been able to access live view, it fails to work 99% of the time, becoming stuck on "launching live view."

Interestingly, when attempting to access the live view, my router's "current connected devices" menu displays the SimpliSafe camera as connected, but the live view never actually launches. To troubleshoot, I've tried the following steps based on community posts and documentation:

Disabled Wi-Fi 6
Changed the control channel to channel 11
Switched security settings to just "WPA2 Personal" and also the combined setting of "WPA/WPA2 Personal", neither worked

I have also done a complete reset of the Base Station and re-connected to the Wifi after adjusting all of my router settings. Obviously, to no avail.


Sadly, none of these adjustments have resolved the issue. It's increasingly frustrating, as the camera's functionality is a primary reason for subscribing to SimpliSafe's service, and returning to my old router is not an option.

I would greatly appreciate any suggestions or advice from the community on how to approach this problem, as I'm eager to have a fully functional and reliable security system. If anyone has encountered a similar issue and found a successful resolution, please share your experience.

Community Admin

 • 

2.4K Messages

 • 

10 Points

11 months ago

Hi @therikkening, 

I'm so sorry to hear that you've been experiencing trouble with your Outdoor Camera recently.

Have you tried running the Connection Check tool in the SimpliSafe mobile app? This will allow you to see how strong your Outdoor Camera’s internet connection is, as a weak connection can impact the Outdoor Camera's performance. You can access this in the app by going to Cameras > Settings > [your camera] > Connection Check > Start Connection Check.

If a weak connection is shown, we do list some steps on improving Wi-Fi signal strength in our Help Center

2 Messages

10 months ago

My issue occurs even if the Camera is sitting right next to the router. I've tried the connection check option, of course.

I'm just going to cancel my SimpliSafe.

Community Admin

 • 

2.4K Messages

 • 

10 Points

Hi @therikkening​,  

I see that you called our support team and they're sending you a new camera. If you continue to experience the same issue, please let us know!

New to the Community? Get started by reading our Welcome Post.