‎Base Wont Recognize Glass Break Sensors | SimpliSafe Support Home
 
C

Friday, May 1st, 2020 2:06 PM

Base Wont Recognize Glass Break Sensors

Bought two new glass break sensors, but the base won't recognize them. Tried adding them through the keypad and online. System searches but doesn't find them. Can anyone help?

1.2K Messages

4 years ago

Are you pressing the button on the sensor to put it into pairing mode?

4 years ago

Yep.

4 years ago

You're referring to the test button on top I assume?

1.2K Messages

4 years ago

Yeah.  Usually they add without incident.  Have you tried new batteries?  Maybe you got some that arrived dead.

4 years ago

I'll try it. The light illuminates when I press the button.

4 years ago

I have two, and neither one wlll register.

1.2K Messages

4 years ago

I wonder if you got the wrong glass break sensors.  In case you aren't aware there are 2 models of SS, the older and the newer.  The sensors are not interchangeable.

4 years ago

I purchased them from Simplisafe.

4 years ago

These are the ones I received (not these exact sensors, of course).

https://www.ebay.com/i/223744357967?chn=ps&norover=1&mkevt=1&mkrid=711-117182-37290-0&mkcid=2&itemid=223744357967&targetid=882904020427&device=c&mktype=pla&googleloc=9025384&poi=&campaignid=6469981122&mkgroupid=86285324342&rlsatarget=pla-882904020427&abcId=1141176&merchantid=6296724&gclid=Cj0KCQjwka_1BRCPARIsAMlUmErx-CiRbC0wtqoegiGqNU4P4HPZRq3L-k83W-33DRrnPYA6qowYSIEaAsAeEALw_wcB

Advocate

 • 

2.8K Messages

 • 

10 Points

4 years ago

^ Here's the link to the two different systems - the older system, SS2 is called the "Original Simplisafe", the newest, SS3 is called the "All New Simplisafe" - click on the base station that matches yours, to see/purchase options for the corresponding sensors for that base station.  

https://simplisafe.com/alarm-sensors

If you have the correct sensors, call SS and ask for assistance in getting them working correctly.
New to the Community? Get started by reading our Welcome Post.