‎Angus | SimpliSafe Support Home
 
Angus's profile

15 Messages

Thursday, August 11th, 2022 6:44 PM

Angus

Wow.  SimpliSafe "support" seems to be an absolute joke.  We tried to incorporate the "doorbell pro" into our system.  None of the three doorbell pros they've sent work.  When online with "support," for over two hours (total) over the last two weeks, it has become apparent that most of the folks answering the "support" calls have no clue about either the hardware or the software they are troubleshooting by phone.  Some believe that the necessary (?) "chime connector" is included in the doorbell pro unit.  Some believe it is a separate item that is necessary to make the doorbell pro work in most circumstances.  When they sent out the THIRD doorbell pro, they said they were also sending out a "chime connector," but there was no separate item, just another doorbell pro that wouldn't work.  We were then told the the "chime connector" is incorporated into the doorbell pro.  Now that the THIRD doorbell pro does not work, we have been told that we need a separate ""chime connector," which they now say they are sending as a separate item.  In any case, anyone can understand why we've totally lost confidence in SimpliSafe, their product and their customer service/support.  Most times we call, we get off shore providers, receiving their phone calls at home, with dogs barking in the background, children crying and doors slamming.  The support people do not speak English as their first or primary language.  Some are barely understandable, due to their strong accents.  All of the offshore "support" people have been, basically, clueless.  Again, the "doorbell pro" and its customer service/support are an absolute joke.  Someone suggested we send the whole system back for a refund and find another provider.  That might be our best solution.   

Accepted Solution

Official Solution

Community Admin

 • 

5.5K Messages

2 years ago

@Angus​ based on our records, I see that our Specialist was able to reach you today, and has confirmed what I had suspected - that you have a digital chime box, which the Video Doorbell Pro is not compatible with. But I'm glad that we've already gotten the return process underway. Again, apologies for the delay in getting this sorted. Let us know if you need any further help.

This comment was created from this reply

15 Messages

@davey_d​ Alex rocked.  It was refreshing to speak with someone who clearly had both adequate training and experience in resolving this issue.  Yes, we have the return protocol in process.  It is my understanding that I am to wait for another return label.  I have the units boxed up; will seal and send as soon as the new return label arrives.  THANK YOU for facilitating a phone back with someone who was not only knowledgeable, but also someone with good diction, syntax and pronunciation.  Both knowledge and basic communication are essential components of meaningful "support" and "customer service."  Thanks, again.  Alex did a great job. 

Captain

 • 

5.9K Messages

2 years ago

@Angus Not a good post to read for sure, and I have a friend who is a Systems Network Security Engineer for a large IT consulting firm, who had a similar experience as you. I recommended SS to him, loved the system but was ready to pull his hair out with the doorbell pro, especially when I told him mine, and two other dozen units I recommended on systems I placed, were doing quite nicely. I suggested the following, which he did:  He called in, spoke with an agent and politely asked to referred to a product specialist. He was told that didn't exist but instisted (again politely but firmly) he be contacted by a specialist no matter what the title was. Next day a call came from a "technical specialist" who got down to business with amperage, voltage and other details I am not qualified to understand, but luckily, my friend did.  I will spare you the details but the issue came down to his chime unit, which he replaced and, tada, the 4th doorbell pro worked.

I suggest you try the same. Repeating the same cycle of steps is insantity and if this doesn't work, and you are within the 60 days, understand completely why you would return everything.

SS, time to step up.

15 Messages

@captain11​ Sadly, as an update, SS certainly hasn't "stepped up."  I have been so desperate to not scrap the entire system by redeeming this "Doorbell Pro," that I've been working every possible avenue of communication with SS; Facebook messaging, phone calls and this forum . . . all to no avail.  However, we are learning to lower our expectations.  We realize from reading other comments, that SS "support" and "customer service" are pretty pathetic.  We get lip service and promises, but, so far, no definitive answers.  We are taking tentative encouragement from your message, above, however.  Yet a fourth, unexpected "Doorbell Pro" arrived today.  Maybe our fourth will work like your friend's.  I would also add that none of the SS "support" folks I've spoken with (most of whom are off shore . . . way off shore) clearly have absolutely no practical or meaningful experience or expertise in addressing voltage (mine is the typical 17v), much less amperage or other details.  Some have led me to believe that the "chime connector" will solve (magically moderate) all electrical issues on a wired doorbell system.  Others dissent.  Some SS "support" people errantly believed that the "chime connector" is incorporated into the Doorbell Pro button housing.  This suggests they also have no clue about their product.  Why this assertion?  One other, finally confirmed the "chime connector" is, in fact, another, separate device intended to be attached to the existing doorbell chime.  It appears SS FINALLY has a "chime connector" en route, after twice promising it, only to simply send us another doorbell.  In any case, my post and comment only state the facts.  The reason both my original post and this reply might be distasteful would simply be because SS support and customer service, in this case, have not been "good," at all.  And, I can imagine no logical reason why SS would continue to send out doorbells that do not work.  Why hasn't this issue, whether software or hardware, been resolved?  

   

15 Messages

@captain11​ See above.  A domestic support specialist finally phoned back.  He rocked.  Within .5 hour, we finally determined the cause of the issue: "digital" chime box (old Heathco WL-106-A) cannot be reliably made compatible.  We decided to just add another dedicated front door camera and hook up the old doorbell button.  Also, when I went to hook up the old doorbell button, I noticed the prior property owner had a diode incorporated into the doorbell button.  This was obviously "aftermarket."  I kept it in place.  Hmmmm.  I wonder what is up with that.  Time for some more research.  Anyway, SS finally came through. 

Community Admin

 • 

5.5K Messages

2 years ago

Hi @Angus ,

I agree with the Captain. This experience that you've had is way below our standard. I do want to make it clear that while we do have a diverse crew among our Support staff across the country, many of whom have been working from home since the start of the pandemic, all of them are fully trained to provide support in English.

Reading more into your issue, though, we should have first started by verifying that you are installing your Video Doorbell Pro into a wired analog/mechanical doorbell. If you have a multi-tone or digital doorbell system, the Video Doorbell Pro may not be compatible.

But once we verify that, the next part is to explain the Chime Connector, which is a piece of wiring that helps deliver the correct amount of power to your Video Doorbell. It is not usually required except in rare cases, which is why it is not included in the Video Doorbell package and should be sent as a separate item.

Since you've mentioned, you are now several calls in with our Support team without a resolution, I'm going to create a ticket with a Specialist myself. They'll give you a call and get your situation resolved ASAP.

(edited)

15 Messages

@davey_d​ Davey, most of your Support staff that I've talked to are NOT in country.  At this point, based on their inconsistency of technical information alone, they are clearly not well trained.  "Diversity" is not the issue.  Competence, including English fluency, is.  Because their first language is not English, their poor diction, syntax and pronunciation result in garbled communication.  Please do "create a ticket with a Specialist."  We are still waiting.  As noted below, a fourth "Doorbell Pro" arrived today.  We also received notice that a "chime connector" is en route.  We hope that notice is true.  Some of your support staff have led us to believe that a "chime connector" will solve all of our problems, including any electrical anomaly they suspect we might be experiencing.  Please note, I've confirmed the typical 17v at the doorbell site, wires and plate contacts.  We'd much prefer to have a completely integrated SS system, including the SS doorbell cam.  It seems we desperately need to have someone with real "Doorbell Pro" expertise and experience.  It is pretty pathetic, to us, to have your "support" staff try to push us off to $129.99/hour ontechsmartservices when the deficiency seems to be with your product, not our physical set up or ability to follow directions.  

15 Messages

@davey_d​ What happened to our call from a SS specialist?  What happened to getting our "situation resolved ASAP?  You (two days ago) and the monitors on FB (Thursday at 15:23) both promised call backs.  What happened?  Just lip service?  Remember the saying, "Actions speak louder than words?"  Same with inaction.  Inaction speaks louder than words about your level of commitment to "support" and/or customer service.  So, so, so sad.  Again, what's up?   

Community Admin

 • 

5.5K Messages

@Angus​ based on our records, I see that our Specialist was able to reach you today, and has confirmed what I had suspected - that you have a digital chime box, which the Video Doorbell Pro is not compatible with. But I'm glad that we've already gotten the return process underway. Again, apologies for the delay in getting this sorted. Let us know if you need any further help.

This reply has been converted into a comment
New to the Community? Get started by reading our Welcome Article and please be sure to review our Community Guidelines before posting.