‎Can't load Android 8 on my old phone | SimpliSafe Support Home
 
diverjer's profile

Monday, July 11th, 2022 7:38 PM

Can't load Android 8 on my old phone

Can't load Android 8 on my old phone, stuck on V7,  will I be able to use the app After July 31?  Got the following email fro SimpliSafe:

At least one mobile device linked to your SimpliSafe account won’t be able to support the next update for the SimpliSafe app, which is scheduled for the end of July.

This update requires the Android operating system 8.0 or higher.

We want to make sure your app has the latest features, so we highly recommend you upgrade your operating system. It’s free and easy to do. Click the here for instructions on updating your Android operating system.

If you do not upgrade your operating system, you can still use the Simplisafe app, but it will no longer receive important security enhancements from the Google Play Store.

Please don’t hesitate to contact us with any questions or concerns. Thanks for staying up to date!

Official Solution

Community Admin

 • 

5.3K Messages

2 years ago

Hi @diverjer ,

Unfortunately yes, this is correct. You'll need to have Android 8 or higher to install the SimpliSafe app on your phone. If already installed, it will not stop working immediately. But at some point in the future, you would also no longer be able to log in.

Though you would still be able to use the webapp from your browser, which supports some (but not all) app features.

In case Apple users are curious, the minimum for you is iOS14.

New to the Community? Get started by reading our Welcome Post.