‎Login page shows blank, unable to log into account | SimpliSafe Support Home
 
longl44's profile

Tuesday, July 7th, 2020 12:47 PM

Login page shows blank, unable to log into account

Don't know where to post this so starting here. I can't log int my account from main page. When I click on "log in" it opens a blank page and nothing happens. I can log in on the forums page. When logged in from forum link I still can't "view account". Help please.

This post refers to an issue that has been resolved. If you are having difficulty with logging into your SimpliSafe account, give us a all at 800-548-9508. Or Support team would be happy to assist.

3 years ago

SAME issue,  I think they should stop the commercial before being sued for false advertising.  I'm very embarrassed for I gave high praise to my neighbor on Simple Safe.

1 Message

3 years ago

I cannot log into the account.   I get the email with verification, click on the verify, get a screen that says verification successful, then nothing

Community Admin

 • 

521 Messages

3 years ago

Hi @bjorn4119,

Could you be more specific about what is not working when you try to log in through Chrome? Are you experiencing the same issue that some others have mentioned in that you get stuck in some sort of verification loop? In Chrome, have you tried logging into your SimpliSafe account through an Incognito window? Doing so would help see if an extension installed in Chrome may be causing your issue.

SimpliSafe Social Team
SimpliSafe Home Security

2 Messages

Issue Resolved.

I turned off my ad blocker. Problem solved.

Community Admin

 • 

521 Messages

3 years ago

Hi @bjorn4119,

Thanks for letting us know what resolved your issue! Doing so helps ensure that future SimpliSafers who come to this thread experiencing the same issue will know to check to see if an ad blocker is causing the issue for them as well. We really appreciate it.

SimpliSafe Social Team
SimpliSafe Home Security

Community Admin

 • 

521 Messages

3 years ago

Hi @lindahunternicoll,

Would you be able to give us some more information as to where the login process is going wrong? Is it that you are getting stuck in a verification loop, that you are getting a blank screen after logging in, or something else? Also, have you tried any of the troubleshooting steps mentioned in this thread?

SimpliSafe Social Team
SimpliSafe Home Security

1 Message

2 years ago

What does "wireless interference detected" mean?  Happening about every 5 seconds

This comment has been converted into a post

1 Message

2 years ago

I had received phone messages that Simplisafe had sent me a module, however they never called me before mailing it.  I had moved 3 years prior.  They sent it to the wrong address.  They took no responsibility for not verifying my correct address.  They refused to credit my account, even though my system did not work.  Then when I did receive the module at the correct address, they still show my old address as my billing address.  And I cannot log onto my account to change my credit card.

Community Admin

 • 

5.3K Messages

@caryldevaney​ sorry to hear about your situation. I've created a ticket with our Specialist team to get your issues resolved ASAP.

1 Message

2 years ago

Useless page.  I'm trying to log into my account.  I have had four codes sent to me.  Each time I verify the code, the same screen appears.  If my account gets cancelled I'll just go to another security system company.

This comment has been converted into a post

1 Message

2 years ago

I would like a phone # so I could call you! 

This comment was created from this reply

Community Admin

 • 

5.3K Messages

@tom0903​ you're looking for the general Support phone number? That would be 800-548-9508!

1 Message

2 years ago

Your log in sucks big time I have been trying to log in to my account to change my bill paying method . Good luck when you send the bill.. Guess will find another company 

This comment has been converted into a post

3 Messages

2 years ago

It is impossible to use this company any more you can never log in and get anything

This comment has been converted into a post

2 Messages

1 year ago

Entry Sensor blinks 3 times when I press test button.  Base Station says entry sensor is not responding. What now?

This comment has been converted into a post

1 year ago

i have been 3 days and over 5 hrs on the phone trying to get this system to work,,im done,,im tired,, whats the rerturn policy

Community Admin

 • 

2.6K Messages

Hi @jimmydebbie953​, 

I would be more than happy to help you with your system. What issues are you experiencing, and what troubleshooting steps have you already taken on the phone with customer service? This will be helpful to know what we should do next.

New to the Community? Get started by reading our Welcome Post.